Mailer-Project Community

Support&Community Forum

clarity
Mailer-Project Community » Free-Hoster Support - Archiv » Patches Installiert trozdem fehler

Patches Installiert trozdem fehler

Locked

Page: 1

Author Post
Serkan
Guest
HI,
Ich hab mich bei einem freehoster angemeldet um den Script erst mal zu testen und mich mit dem Script eben vertraut zu machen. Nun am anfang lief erst mal garnix, hab im Forum rumgeschaut und weiter gekommen, trozdem gibbts noch fehler. siehe: Link entfernt

Fehler:
Laufzeit-Problem erkannt!

Fataler Fehler Nr. #1:
� /var/kunden/webs/web2/user_web/serkanb/inc/load_extensions.php (191):Unknown column 'has_menu' in 'field list'
MySQL-Abfragebefehl war:
SELECT has_menu FROM mxchange_mod_reg WHERE module='order' LIMIT 1
Fataler Fehler Nr. #2:
� /var/kunden/webs/web2/user_web/serkanb/inc/load_extensions.php (191):Unknown column 'has_menu' in 'field list'
MySQL-Abfragebefehl war:
SELECT has_menu FROM mxchange_mod_reg WHERE module='register' LIMIT 1
Fataler Fehler Nr. #3:
� /var/kunden/webs/web2/user_web/serkanb/inc/load_extensions.php (191):Unknown column 'has_menu' in 'field list'
MySQL-Abfragebefehl war:
SELECT has_menu FROM mxchange_mod_reg WHERE module='support' LIMIT 1

also ich hab zwar bissl ahnung mit HTML, aber bin neu was Datenbanken betrifft. Hilfe w�re jetzt nett.

MfG
Serkan
« Last edit by Quix0r on Thu Feb 14, 2008 6:41 pm. »
Serkan
Guest
Hab das Problem gel�st.
Einfach alles neu hochgeladen und neu installiert inkl. alle neueren Patches.
Project Founder
Registered: Sep 2005
Posts: 1395
Location: Krefeld
Okay, habe alles gelesen und nachgedacht. Ich denke, dann hast du auch das mxchange-Archiv PL-511runtergeladen? Das "normal" (ohne PL-511) ist fehlerhaft.
_______________
News-Flash: - Bitte den Bug-Tracker mehr nutzen! - Wiki verfuegbar - Bitte die neuste GIT-Revision von dieser Anleitung - Topic 180 herunterladen - Bug-Rallye gestartet! - Historisches Archiv angelegt - SVN-Howto - Commit-Statistik Feb 2008 - dato
Serkan
Guest
also ich hab wegen nem neuen Problem mal wieder alles gel�scht, konnt mich nur einmal einloggen.

so nun hab ich mal die datein so wie auf http://forum.mxchange.org/topic-150.html
ganz unten beschrieben zusammen gesetzt und hochgeladen.
die Dateiattribute wie folgt gesetzt:

- 777 auf inc
- 777 auf inc/.secret/
- 666 auf inc/config.php
- 644 auf alle 4 SQL-Dateien

Installation beendet.
Admin-acc erstellt.
Dateiattribute:
Verzeichniss inc und datei inc/config.php auf 755, weil:
"Laufzeit-Problem erkannt!

Fataler Fehler Nr. #1:
� Ihre Datei inc/config.php ist beschreibbar! Dies ist ein m�gliches Sicherheitsrisiko!
Fataler Fehler Nr. #2:
� Das Verzeichnis inc ist beschreibbar! Bitte setzen Sie die Zugriffsrechte auf 755 oder 555."

Einloggen Adminbereich.
Ausloggen Adminbereich.
"Klicken Sie hier, um sich erneut einzuloggen." geklickt.
versuch einzuloggen gescheitert...

Nun das ist alles was ich gemacht hab. ich weis nich worans liegt. Passwort kann nicht falsch sein, 1. es ist zum test nur 4-stellig und 2. Firefox setzt diesen automatisch.

Also was kann ich machen damits l�uft?

Danke schon mal jetzte.

beim 2. mal lesen f�llts mir auf:"Das "normal" (ohne PL-511) ist fehlerhaft." wieso das normal? ich hab n zip ordner geladen mit dem Namen "mxchange-testing_0.2.0-pre10_PL511" ist das der Falsche?
« Last edit by Unknown on Tue Aug 08, 2006 12:08 am. »
Project Founder
Registered: Sep 2005
Posts: 1395
Location: Krefeld
Genau das ist das richtige, wegen dem PL511 am Ende. :)

Soweit sieht alles gut aus, wegen der Zugriffsrechte. Und es scheinen auch Tabellen bei der Installation in der Datenbank angelegt worden zu sein.

Das mit dem Loginfehler schaetze ich auf fehlende Cookies. Du hast doch Firefox, dann gucke mal nach, ob ueberhaupt Cookies fuer deine Subdomain gesetzt worden sind. Oder ob Firefox sie sperrt. Geht ueber Einstellungen -> Privatsfaehre (oder so?) und dann Cookies.

Roland
_______________
News-Flash: - Bitte den Bug-Tracker mehr nutzen! - Wiki verfuegbar - Bitte die neuste GIT-Revision von dieser Anleitung - Topic 180 herunterladen - Bug-Rallye gestartet! - Historisches Archiv angelegt - SVN-Howto - Commit-Statistik Feb 2008 - dato
Serkan
Guest
ja da sind 3 Cookies von meiner Subdomain:

-mxchange_theme
-mx_lang
-PHPSESSID
Project Founder
Registered: Sep 2005
Posts: 1395
Location: Krefeld
Gut, dann kann es daran nicht liegen. Sonst setze mal das Passwort neu mit:

UPDATE mxchange_admins SET password=MD5('geheim')


Statt geheim natuerlich dein Passwort. :) Und das innerhalb der beiden Abostrophe.

Beim naechsten Login-Versuch sollte eigentlich die MD5-Summe in die neue "gesalzene" Checksumme umgewandelt werden. Rufe mal in phpMyAdmin die Tabelle mxchange_config auf und klicke auf "Anzeigen/Browse". Ist in den Spalten salt_length, pass_scramble, rand_no, file_hash und master_salt je etwas eingetragen?

Bitte die Werte hier nicht anzeigen, da sie geheim bleiben sollten.
_______________
News-Flash: - Bitte den Bug-Tracker mehr nutzen! - Wiki verfuegbar - Bitte die neuste GIT-Revision von dieser Anleitung - Topic 180 herunterladen - Bug-Rallye gestartet! - Historisches Archiv angelegt - SVN-Howto - Commit-Statistik Feb 2008 - dato
Serkan
Guest
Nach dem ich diesen Befehl ausgef�hrt hab konnt ich mich wieder einloggen.

Ich hab nach diesen Spalten gesucht und auch die Suchfunktion von Firefox benutzt, aber keines von denen hab ich gefunden.

Und nach dem aussloggen konnt ich wieder nicht rein, aber denke mal das wundert dich jetzt nicht das ich nicht wieder rein konnt.
Project Founder
Registered: Sep 2005
Posts: 1395
Location: Krefeld
Das ist seltsam... :-( Hast du auch die aktuelle Version von der Erweiterung sql_patches installiert?

Hier der Link zu allen Erweiterungen:
http://www.mxchange.org/cms/index/wht/extensions
_______________
News-Flash: - Bitte den Bug-Tracker mehr nutzen! - Wiki verfuegbar - Bitte die neuste GIT-Revision von dieser Anleitung - Topic 180 herunterladen - Bug-Rallye gestartet! - Historisches Archiv angelegt - SVN-Howto - Commit-Statistik Feb 2008 - dato
Serkan
Guest
Habs runtergeladen, hochgeladen geht net.
hab dieses SQL-befehl ausgef�hrt, eingeloggt und wieder ausgeloggt, nun gehts wieder nicht.

Also keine �nderung zu sehn...
Project Founder
Registered: Sep 2005
Posts: 1395
Location: Krefeld
Dann kann ich hier auch dichtmachen. :/
_______________
News-Flash: - Bitte den Bug-Tracker mehr nutzen! - Wiki verfuegbar - Bitte die neuste GIT-Revision von dieser Anleitung - Topic 180 herunterladen - Bug-Rallye gestartet! - Historisches Archiv angelegt - SVN-Howto - Commit-Statistik Feb 2008 - dato

Locked

Page: 1

Parse time: 0.2006 s · Memory usage: 0.59 MB · Server load: 1.72 · Template sections: 2 · SQL queries: 9

Nokia GNU GPL v3 YaCy Project Honeypot Stop ACTA!

Mailer-Project Community is powered by UseBB 1 Forum Software

threatening-alpha